[Libav-user] Issue with hardware decoding of H265 video stream via QSV

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[Libav-user] Issue with hardware decoding of H265 video stream via QSV

Vivekanand

Hello,

I am trying to decode H265 frames in hardware (QSV) via ffmpeg (3.4.7) on Intel CPU. Following command works perfectly on terminal ( OS : CentOS):

build/lin_x64/bin/ffmpeg  -c:v hevc_qsv -load_plugin hevc_hw -hwaccel qsv -i <h265-video-name> -f null -

I am trying to re-produce similar behaviour (H265 hardware decoding) via program (C++) but I am unable to do so. I am not able to find code snippet that sets (-hwaccel qsv) option via program.

Command above sets 3 parameters :

  1. -c:v hevc_qsv
    codec = avcodec_find_decoder_by_name("hevc_qsv");

  2. -load_plugin hevc_hw
        int ret1 = av_dict_set(&opts, "load_plugin", "hevc_hw", 0);

      
    and later on passing this to :
       int ret2 = avcodec_open2(avctx, codec, &opts);

  3. -hwaccel qsv
     
    <Need snippet demonstrating this setting>

I am not able to set -hwaccel qsv via program, need code snippet demonstrating same (-hwaccel qsv)

Current program gives following error :
      [hevc_qsv @ 0x15d1530] Error initializing the MFX video decoder: invalid video parameters (-15)

Sample code and video can be downloaded for link below :  (README has some more information about code. As a end goal, attached program is supposed to decode H265 frames using intel QSV)

https://www.dropbox.com/s/pcdbjmzrpdnjpi0/testH265.tgz?dl=0

--
Thanks,
Vivekanand



_______________________________________________
Libav-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/libav-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".