[Libav-user] NvEnc 9.0 but requires NvEnc 9.1

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Libav-user] NvEnc 9.0 but requires NvEnc 9.1

Philippe Noël
Hello,

I'm trying to use Libav to encode a video to H.264 using Nvidia NvEnc. Unfortunately, I am working on a Windows Server VM (on which I do not have access to the Nvidia drivers) and the code fails saying it requires NvEnc 9.1, which is available with a higher generation of Nvidia drivers.

After a brief search it appears I need to "downgrade" Libav to a version which uses NvEnc 9.0 instead of 9.1. I downloaded the .lib files from Zerano (from the main ffmpeg.org website), so I have no idea how to compile it. Is it possible somewhere to obtain those static libs directly for the version which supports NvEnc 9.0? What is that version, if anyone knows?

Cheers,

Philippe

_______________________________________________
Libav-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/libav-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: NvEnc 9.0 but requires NvEnc 9.1

Strahinja Radman

Hello,

I'm trying to use Libav to encode a video to H.264 using Nvidia NvEnc. Unfortunately, I am working on a Windows Server VM (on which I do not have access to the Nvidia drivers) and the code fails saying it requires NvEnc 9.1, which is available with a higher generation of Nvidia drivers.

After a brief search it appears I need to "downgrade" Libav to a version which uses NvEnc 9.0 instead of 9.1. I downloaded the .lib files from Zerano (from the main ffmpeg.org website), so I have no idea how to compile it. Is it possible somewhere to obtain those static libs directly for the version which supports NvEnc 9.0? What is that version, if anyone knows?

Cheers,

Philippe
_______________________________________________
Libav-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/libav-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".


Here is a link to previous static builds of FFmpeg by Zeranoe. https://ffmpeg.zeranoe.com/builds/win64/static/ Probably some of the binaries will contain NVENC 9.0. See when NVENC 9.0 was released and 
date match with the Zeranoe build.

--

Regards
Strahinja Radman

_______________________________________________
Libav-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/libav-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".