[Libav-user] Trouble with afade filter on Android x86 Device

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Libav-user] Trouble with afade filter on Android x86 Device

libav-users mailing list


Hello All,


I am having some trouble getting an af_afade filter to work on in a native (c++) android program. Swapping out the afade filter for a "volume" filter allows me to change the frame volume as expected, but no configuration of the afade filter seems to modify the frame at all.


I am cross compiling ffmpeg from linux with the configure options shown in ffmpeg_configure.sh, setting up the filter graph as shown in ffmpeg_filterSetup.c, and passing the frame in as shown in ffmpeg_useFilter.c (After having received it from an AVCodecContext object, and before resampling it with "swr_convert_frame").


Would really appreciate any help anyone can provide!

Thanks,

Sam



_______________________________________________
Libav-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/libav-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: Trouble with afade filter on Android x86 Device

libav-users mailing list

Of course, I forgot the attachments.


From: Libav-user <[hidden email]> on behalf of Coulter, Sam via Libav-user <[hidden email]>
Sent: Wednesday, November 6, 2019 5:07 PM
To: [hidden email]
Cc: Coulter, Sam
Subject: [Libav-user] Trouble with afade filter on Android x86 Device
 


Hello All,


I am having some trouble getting an af_afade filter to work on in a native (c++) android program. Swapping out the afade filter for a "volume" filter allows me to change the frame volume as expected, but no configuration of the afade filter seems to modify the frame at all.


I am cross compiling ffmpeg from linux with the configure options shown in ffmpeg_configure.sh, setting up the filter graph as shown in ffmpeg_filterSetup.c, and passing the frame in as shown in ffmpeg_useFilter.c (After having received it from an AVCodecContext object, and before resampling it with "swr_convert_frame").


Would really appreciate any help anyone can provide!

Thanks,

Sam



_______________________________________________
Libav-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/libav-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".

ffmpeg_useFilter.c (400 bytes) Download Attachment
ffmpeg_filterSetup.c (3K) Download Attachment
ffmpeg_configure.sh (1K) Download Attachment