[Libav-user] Upgrade guide?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Libav-user] Upgrade guide?

Helmut Jarausch
Hi,
on my Gentoo system there are some packages which don't compile any  
more after upgrading from  ffmpeg-2.8.10 to ffmpeg-3.2.2
Is there any guide for upgrading those applications?

Many thanks,
Helmut
_______________________________________________
Libav-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/libav-user
Lou
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade guide?

Lou
On Sun, Dec 11, 2016, at 03:10 AM, Helmut Jarausch wrote:
> Hi,
> on my Gentoo system there are some packages which don't compile any  
> more after upgrading from  ffmpeg-2.8.10 to ffmpeg-3.2.2
> Is there any guide for upgrading those applications?

When the major number of a release changes (such as from 2.8 to 3.2) it
involves backward incompatible changes, so it can be expected that
applications that use FFmpeg may not compile if they have not made
appropriate changes to their code. You should refer to the help
resources of the downstream applications. We can't support third-party
tools here.

See "Versioning and compatibility" for more details:
https://www.ffmpeg.org/doxygen/trunk/
_______________________________________________
Libav-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/libav-user