[Libav-user] Why is length and bitrate zero?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[Libav-user] Why is length and bitrate zero?

Michael Heuberger
Hello folks

I just have encoded a webm video with a duration of about 2 mins. But
when I play it on a website or in a video player, it tells me length is
zero. Weird. So I have inspected it in my local Ubuntu SM video player,
see attached image. Indeed, length and bitrate are zero.

This is the ffmpeg command I used to encode the video based on image frames:

ffmpeg -f image2 -thread_queue_size 2048 -framerate 18.9 -i
/home/michael-heuberger/binarykitchen/code/videomail.io/var/local/tmp/clients/videomail.io/11e6-c1e3-fc2ad020-ae4a-290f0f20d08f/frames/%d.webp
-y -an -vcodec libvpx -filter:v
drawtext=fontfile=/home/michael-heuberger/binarykitchen/code/videomail.io/src/assets/fonts/Varela-Regular.ttf:text=www.videomail.io:fontsize=10:fontcolor=0xFFFFFF@0.25:x=text_h:y=main_h-(text_h*2):shadowcolor=0x111111@0.15:shadowx=1:shadowy=1,scale=trunc(iw/2)*2:trunc(ih/2)*2
-crf 8 -pix_fmt yuv420p -deadline good -cpu-used 1 -loglevel warning
/home/michael-heuberger/binarykitchen/code/videomail.io/var/local/uploads/videomail.io/videomail/11e6/c1/e3/11e6-c1e3-fc2ad020-ae4a-290f0f20d08f/videomail_good.webm

Yes, it is a bit long and has a lot in it. It's for the www.videomail.io
webservice.

But I hope someone of you can spot what I am doing wrong with the ffmpeg
parameters. Is there a reason why bitrate and length is zero?

Thanks for any clues!
Michael

--

Binary Kitchen
Michael Heuberger
1/33 Parrish Road
Sandringham
Auckland 1025
(New Zealand)

Mobile (text only) ...  +64 21 261 89 81
Email ................  [hidden email]
Website ..............  http://www.binarykitchen.com


_______________________________________________
Libav-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/libav-user

example-webm-info.png (46K) Download Attachment
Lou
Reply | Threaded
Open this post in threaded view
|

Re: Why is length and bitrate zero?

Lou
On Wed, Dec 14, 2016, at 01:01 AM, Michael Heuberger wrote:
> Hello folks
>
> I just have encoded a webm video with a duration of about 2 mins. But
> when I play it on a website or in a video player, it tells me length is
> zero. Weird. So I have inspected it in my local Ubuntu SM video player,
> see attached image. Indeed, length and bitrate are zero.
[...]

This is the mailing list for questions involving the FFmpeg libraries.
Questions involving the FFmpeg cli tools should be asked at ffmpeg-user.
_______________________________________________
Libav-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/libav-user
Reply | Threaded
Open this post in threaded view
|

Re: Why is length and bitrate zero?

Michael Heuberger
Thanks for the hint. Will ask there. Wasn't obvious to me on the landing
page.

Cheers
Michael


On 18/12/16 15:09, Lou wrote:

> On Wed, Dec 14, 2016, at 01:01 AM, Michael Heuberger wrote:
>> Hello folks
>>
>> I just have encoded a webm video with a duration of about 2 mins. But
>> when I play it on a website or in a video player, it tells me length is
>> zero. Weird. So I have inspected it in my local Ubuntu SM video player,
>> see attached image. Indeed, length and bitrate are zero.
> [...]
>
> This is the mailing list for questions involving the FFmpeg libraries.
> Questions involving the FFmpeg cli tools should be asked at ffmpeg-user.
> _______________________________________________
> Libav-user mailing list
> [hidden email]
> http://ffmpeg.org/mailman/listinfo/libav-user

--

Binary Kitchen
Michael Heuberger
1/33 Parrish Road
Sandringham
Auckland 1025
(New Zealand)

Mobile (text only) ...  +64 21 261 89 81
Email ................  [hidden email]
Website ..............  http://www.binarykitchen.com

_______________________________________________
Libav-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/libav-user