[Libav-user] libmfx not found using pkg-config

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Libav-user] libmfx not found using pkg-config

francesco
Hi to all
I'm attempting to compile ffmpeg using VS2015 with --enable--static and
--enable-libmfx.  I can compile without
enable libmfx, but I can't compile enabling it.  Command I sent is:

./configure --enable-yasm --enable-asm --enable-gpl --enable-static
--disable-debug --arch=amd64 --toolchain=msvc

it seems that libmfx is correctly installed:

pkg-config --libs libmfx
-L/msvc/lib -lmfx -lstdc++

but the result is "ERROR: libmfx not found using pkg-config".  I attempt
to compile using mingw64 only:

./configure --enable-yasm   --enable-gpl --enable-static --disable-debug
--arch=amd64

but same result.  Same result too if I don't specify architecture:

/configure --enable-yasm   --enable-gpl --enable-static --disable-debug

May be that libmfx can't be statically linked ?
Regards
Francesco




_______________________________________________
Libav-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/libav-user
Loading...